Your submission was sent successfully! Close

CVE-2021-32027

Published: 14 May 2021

A flaw was found in postgresql in versions before 13.3, before 12.7, before 11.12, before 10.17 and before 9.6.22. While modifying certain SQL array values, missing bounds checks let authenticated database users write arbitrary bytes to a wide area of server memory. The highest threat from this vulnerability is to data confidentiality and integrity as well as system availability.

Priority

Medium

CVSS 3 base score: 8.8

Status

Package Release Status
postgresql-10
Launchpad, Ubuntu, Debian
bionic
Released (10.17-0ubuntu0.18.04.1)
focal Does not exist

groovy Does not exist

hirsute Does not exist

impish Does not exist

jammy Does not exist

precise Does not exist

trusty Does not exist

upstream
Released (10.17)
xenial Does not exist

postgresql-12
Launchpad, Ubuntu, Debian
bionic Does not exist

focal
Released (12.7-0ubuntu0.20.04.1)
groovy
Released (12.7-0ubuntu0.20.10.1)
hirsute Does not exist

impish Does not exist

jammy Does not exist

precise Does not exist

trusty Does not exist

upstream
Released (12.7)
xenial Does not exist

postgresql-13
Launchpad, Ubuntu, Debian
bionic Does not exist

focal Does not exist

groovy Does not exist

hirsute
Released (13.3-0ubuntu0.21.04.1)
impish Not vulnerable
(13.3-1)
jammy Does not exist

trusty Does not exist

upstream
Released (13.3)
xenial Does not exist

postgresql-9.1
Launchpad, Ubuntu, Debian
bionic Does not exist

focal Does not exist

groovy Does not exist

hirsute Does not exist

impish Does not exist

jammy Does not exist

precise Ignored

trusty Does not exist

upstream Needs triage

xenial Does not exist

postgresql-9.3
Launchpad, Ubuntu, Debian
bionic Does not exist

focal Does not exist

groovy Does not exist

hirsute Does not exist

impish Does not exist

jammy Does not exist

precise Does not exist

trusty Deferred
(2019-08-23)
upstream Needs triage

xenial Does not exist

postgresql-9.5
Launchpad, Ubuntu, Debian
bionic Does not exist

focal Does not exist

groovy Does not exist

hirsute Does not exist

impish Does not exist

jammy Does not exist

precise Does not exist

trusty Does not exist

upstream Needs triage

xenial Needs triage

Notes

AuthorNote
leosilva
PostgreSQL 9.1 is end of life upstream, and no updates are
are available. Marking as ignored in precise.
PostgreSQL 9.3 is end of life upstream, and no updates are
are available. Marking as deferred in -esm-main releases.

References

Bugs