Your submission was sent successfully! Close

CVE-2021-20225

Published: 2 March 2021

A flaw was found in grub2 in versions prior to 2.06. The option parser allows an attacker to write past the end of a heap-allocated buffer by calling certain commands with a large number of specific short forms of options. The highest threat from this vulnerability is to data confidentiality and integrity as well as system availability.

From the Ubuntu security team

It was discovered that the option parser in GRUB 2 contained a heap overflow vulnerability. A local attacker could use this to execute arbitrary code and bypass UEFI Secure Boot restrictions.

Priority

Medium

CVSS 3 base score: 6.7

Status

Package Release Status
grub2-signed
Launchpad, Ubuntu, Debian
bionic
Released (1.167~18.04.5)
focal
Released (1.167.2)
groovy
Released (1.167.2)
hirsute
Released (1.164)
impish
Released (1.169)
jammy
Released (1.169)
precise Does not exist

trusty Needs triage

upstream Needs triage

xenial Pending
(1.164)
grub2-unsigned
Launchpad, Ubuntu, Debian
bionic
Released (2.04-1ubuntu44.1.2)
focal
Released (2.04-1ubuntu44.2)
groovy
Released (2.04-1ubuntu44.2)
hirsute
Released (2.04-1ubuntu42)
impish
Released (2.04-1ubuntu45)
jammy
Released (2.04-1ubuntu45)
precise Ignored
(end of ESM support, was needs-triage)
trusty Needs triage

upstream Needs triage

xenial Pending
(2.04-1ubuntu42)

Notes

AuthorNote
sbeattie
grub2-unsigned will contain fixes and supersede grub2, which will contain only BIOS grub bits.

References

Bugs