Your submission was sent successfully! Close

CVE-2019-19963

Published: 25 December 2019

An issue was discovered in wolfSSL before 4.3.0 in a non-default configuration where DSA is enabled. DSA signing uses the BEEA algorithm during modular inversion of the nonce, leading to a side-channel attack against the nonce.

Priority

Medium

CVSS 3 base score: 5.3

Status

Package Release Status
wolfssl
Launchpad, Ubuntu, Debian
Upstream
Released (4.3.0+dfsg-1)
Ubuntu 21.10 (Impish Indri) Not vulnerable
(4.3.0+dfsg-2)
Ubuntu 21.04 (Hirsute Hippo) Not vulnerable
(4.3.0+dfsg-2)
Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(4.3.0+dfsg-2)
Ubuntu 18.04 LTS (Bionic Beaver) Needs triage

Ubuntu 16.04 ESM (Xenial Xerus) Ignored
(end of standard support, was needs-triage)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist