CVE-2019-14806

Published: 09 August 2019

Pallets Werkzeug before 0.15.3, when used with Docker, has insufficient debugger PIN randomness because Docker containers share the same machine id.

Priority

Low

CVSS 3 base score: 7.5

Status

Package Release Status
python-werkzeug
Launchpad, Ubuntu, Debian
Upstream
Released (0.15.6+dfsg1-1)
Ubuntu 21.04 (Hirsute Hippo) Not vulnerable

Ubuntu 20.10 (Groovy Gorilla) Not vulnerable

Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(0.16.1+dfsg1-2)
Ubuntu 18.04 LTS (Bionic Beaver)
Released (0.14.1+dfsg1-1ubuntu0.1)
Ubuntu 16.04 LTS (Xenial Xerus) Not vulnerable
(code not present)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist

Ubuntu 12.04 ESM (Precise Pangolin) Does not exist

Patches:
Upstream: https://github.com/pallets/werkzeug/commit/00bc43b1672e662e5e3b8cecd79e67fc968fa246