Your submission was sent successfully! Close

CVE-2018-1061

Published: 19 June 2018

python before versions 2.7.15, 3.4.9, 3.5.6rc1, 3.6.5rc1 and 3.7.0 is vulnerable to catastrophic backtracking in the difflib.IS_LINE_JUNK method. An attacker could use this flaw to cause denial of service.

Priority

Low

CVSS 3 base score: 7.5

Status

Package Release Status
python2.7
Launchpad, Ubuntu, Debian
artful Ignored
(reached end-of-life)
bionic Not vulnerable
(2.7.15~rc1-1)
cosmic Not vulnerable
(2.7.15-4ubuntu1)
disco Not vulnerable
(2.7.15-4ubuntu1)
eoan Not vulnerable
(2.7.15-4ubuntu1)
focal Not vulnerable
(2.7.15-4ubuntu1)
groovy Not vulnerable
(2.7.15-4ubuntu1)
hirsute Not vulnerable
(2.7.15-4ubuntu1)
impish Not vulnerable
(2.7.15-4ubuntu1)
jammy Not vulnerable
(2.7.15-4ubuntu1)
precise
Released (2.7.3-0ubuntu3.11)
trusty
Released (2.7.6-8ubuntu0.5)
upstream Needs triage

xenial
Released (2.7.12-1ubuntu0~16.04.4)
python3.4
Launchpad, Ubuntu, Debian
artful Does not exist

bionic Does not exist

cosmic Does not exist

disco Does not exist

eoan Does not exist

focal Does not exist

groovy Does not exist

hirsute Does not exist

impish Does not exist

jammy Does not exist

precise Does not exist

trusty
Released (3.4.3-1ubuntu1~14.04.7)
upstream Needs triage

xenial Does not exist

python3.5
Launchpad, Ubuntu, Debian
artful Does not exist

bionic Does not exist

cosmic Does not exist

disco Does not exist

eoan Does not exist

focal Does not exist

groovy Does not exist

hirsute Does not exist

impish Does not exist

jammy Does not exist

precise Does not exist

trusty Needed

upstream Needs triage

xenial
Released (3.5.2-2ubuntu0~16.04.5)
python3.6
Launchpad, Ubuntu, Debian
artful Ignored
(reached end-of-life)
bionic Not vulnerable
(3.6.6-1~18.04)
cosmic Not vulnerable
(3.6.6-4)
disco Does not exist

eoan Does not exist

focal Does not exist

groovy Does not exist

hirsute Does not exist

impish Does not exist

jammy Does not exist

precise Does not exist

trusty Does not exist

upstream Needs triage

xenial Does not exist

python3.7
Launchpad, Ubuntu, Debian
artful Ignored
(reached end-of-life)
bionic Not vulnerable
(3.7.0~b3-1)
cosmic Not vulnerable
(3.7.0-1)
disco Not vulnerable
(3.7.0-1)
eoan Not vulnerable
(3.7.0-1)
focal Does not exist

groovy Does not exist

hirsute Does not exist

impish Does not exist

jammy Does not exist

precise Does not exist

trusty Does not exist

upstream Needs triage

xenial Does not exist