CVE-2013-1824

Published: 16 September 2013

The SOAP parser in PHP before 5.3.22 and 5.4.x before 5.4.12 allows remote attackers to read arbitrary files via a SOAP WSDL file containing an XML external entity declaration in conjunction with an entity reference, related to an XML External Entity (XXE) issue in the soap_xmlParseFile and soap_xmlParseMemory functions.

Priority

Medium

Status

Package Release Status
php5
Launchpad, Ubuntu, Debian
Upstream
Released (5.4.4-14, 5.3.23, 5.4.13)
Ubuntu 12.04 ESM (Precise Pangolin)
Released (5.3.10-1ubuntu3.6)

Notes

AuthorNote
mdeslaur this CVE is for an incomplete fix for CVE-2013-1643. Our CVE-2013-1643 did in fact have the complete fix, so we were not affected by this.

References